Перечисления

Перечисления предназначены для описания структуры хранения постоянных наборов значений, не изменяемых в процессе работы конфигурации. Набор значений перечисления задается при конфигурировании системы и не может быть изменен пользователем.

Создать перечисление «Пол». Перейти на закладку «Данные» и создать следующие значения:

Мужской;

Женский.

Перечисление «Пол» представлено на рисунке 52.

Перечисление «Пол»

Рисунок 52 Перечисление «Пол»

Создать перечисление «Должность». Перейти на закладку «Данные» и создать следующие значения:

директор;

продавец;

грузчик;

менеджер;

администратор;

бухгалтер;

кладовщик.

Перечисление «Должность» представлено на рисунке 53.

Перечисление «Должность»

Рисунок 53 Перечисление «Должность»

Создать перечисление «Срок кредита». Перейти на закладку «Данные» и создать следующие значения:

на 6 месяцев;

на 12 месяцев;

на 24 месяца.

Перечисление «Срок кредита» представлено на рисунке 54.

Перечисление «Срок кредита»

Рисунок 54 Перечисление «Срок кредита»

Общие модули

В данной конфигурации будут созданы следующие общие модули:

работа с документами;

работа со справочниками.

Общие модули - объект конфигурации, в котором процедуры и функции, содержащиеся в этом модуле, могут быть доступны для любых объектов конфигурации.

Создать общий модуль «Работа с документами». В открывшемся окне ввести следующий код:

Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт

СтрокаТабличнойЧасти.Сумма=СтрокаТабличнойЧасти.Количество*СтрокаТабличнойЧасти.Цена;

КонецПроцедуры

Процедура РассчитатьСуммуЗП(СтрокаТабличнойЧасти) Экспорт

СтрокаТабличнойЧасти.Итого=СтрокаТабличнойЧасти.ТарифнаяСтавка+СтрокаТабличнойЧасти.Премия;

КонецПроцедуры

Процедура РассчитатьСуммуЗаказа(СтрокаТабличнойЧасти) Экспорт

СтрокаТабличнойЧасти.Сумма=(СтрокаТабличнойЧасти.Цена*СтрокаТабличнойЧасти.Количество)+СтрокаТабличнойЧасти.Доставка;

КонецПроцедуры

Создать общий модуль «Работа со справочниками». В открывшемся окне ввести следующий код:

Функция ЦеныНаТовары(АктуальнаяДата, ЭлементТовар)Экспорт

//Создать вспомогательный объект Отбор

Отбор = Новый Структура("Наименование", ЭлементТовар);

//Получить актуальные значения ресурсов регистра

ЗначенияРесурсов=РегистрыСведений.ЦеныНаТовары.ПолучитьПоследнее(АктуальнаяДата, Отбор);

Возврат ЗначенияРесурсов.Цена;

КонецФункции

Функция ТарифыЗП(АктуальнаяДата, Элемент)Экспорт

//Создать вспомогательный объект Отбор

Отбор = Новый Структура("Работник", Элемент);

//Получить актуальные значения ресурсов регистра

ЗначенияРесурсов=РегистрыСведений.ТарифыЗП.ПолучитьПоследнее(АктуальнаяДата, Отбор);

Возврат ЗначенияРесурсов.Ставка;

КонецФункции

Функция Премии(АктуальнаяДата, Элемент)Экспорт

//Создать вспомогательный объект Отбор

Отбор = Новый Структура("Работник", Элемент);

//Получить актуальные значения ресурсов регистра

ЗначенияРесурсов=РегистрыСведений.Премии.ПолучитьПоследнее(АктуальнаяДата, Отбор);

Возврат ЗначенияРесурсов.Премия;

КонецФункции

 
< Пред   СОДЕРЖАНИЕ   Загрузить   След >